Windows下Python编写APP-kivy的安装

首先我的python是3.7的

看官网说  Kivy 1.11.1是支持Python 2的最新版本。不知道py3怎么样,先试试看把

不过之前官方说 确保您拥有最新的pip,wheel和virtualenv:

    python - m pip install -- upgrade pip wheel setuptools virtualenv

virtualenv的介绍


安装kivy的依赖

官方的:

    python - m pip install docutils pygments pypiwin32 kivy_deps.sdl2 == 0.1.* kivy_deps.glew == 0.1.*     
    python - m pip install kivy_deps.gstreamer == 0.1.*  

(我运行了没反应 我不知道)下面网上找的 懂了 m前空格去掉就好了



    python -m pip install docutils pygments pypiwin32 kivy.deps.sdl2 kivy.deps.glew
    python -m pip install kivy.deps.gstreamer
现在才真的到安装kivy:     python -m pip install kivy==1.11.1

安装 kivy 官方示例:

    python -m pip install kivy_examples

如果安装了kivy示例,您现在应该可以在python中import kivy或运行一个基本示例

本文标签: 安装kivy
转载声明:本文为网中小南的原创文章,转载请注明原文地址,谢谢合作

发表评论: